Le blog d'Azork

Design, techniques et ressources gratuites pour votre site web.

Aller au contenu | Aller au menu | Aller à la recherche

Thème Dotclear - Hybrid

Theme Hybrid

Détails

  • Version du thème : 0.6
  • Licence : domaine public
  • Support : Forum Dotclear

Informations complémentaires

version 0.6

  • Mise à jour de la structure HTML pour simplifier les changements dans les templates (entête et sidebar).
  • L'interligne pour les titres a également été corrigée.
Azork

Auteur: Azork

Restez au courant de l'actualité et abonnez-vous au Flux RSS de cette catégorie

Commentaires (51)

Silvyn! Silvyn! ·  29 septembre 2009, 13:02

Hé mais c'est pas mal du tout ce travail ! Bravo même ! A mon avis je vais l'utiliser pour l'un de mes projets DC.

Azork Unknown Azork Unknown ·  30 septembre 2009, 11:28

@Silvyn > C'est fait pour ça, alors n'hésites pas ! ;-)

Silvyn! Silvyn! ·  08 octobre 2009, 16:21

Bonsoir,
Je pense l'adopter pour le blog VELCS.
Toutefois un truc me gêne beaucoup, il semble y avoir un problème dans l'affichage des annexes.
Est-ce normal ? ou bien il y a-t-il une astuce pour régler ça ?
Merci.

Silvyn! Silvyn! ·  08 octobre 2009, 16:33

Ah j'oubliais ! Je trouve un peu domage de lister sur la page d'accueil les articles sélectionnés en double (avec Articles) et le widget A retenir.
De même qu'on ne puisse pas mettre autre chose que les TAG et les billets A retenir à droite.

Azork Azork ·  09 octobre 2009, 11:44

@Silvyn: Salut, merci de ton feedback.

Concernant les rubriques sur la homepage, je vais essayer de modifier le thème afin que l'on puisse ajouter n'importe quel widget sur la colonne de droite...

ça devrait normalement être disponible semaine prochaine au plutard.

Ciao !

Silvyn! Silvyn! ·  15 octobre 2009, 13:30

Salut,

Merci pour la mise à jour, ça corrige pas mal de choses :)
Pour les TAG's par contre, je n'arrive pas à les voir, comme ici par exemple (http://www.velcs.info/index.php?pos...).
As-tu une solution ?
Merci. Ci@o !

Azork Azork ·  15 octobre 2009, 20:28

@Silvyn!: une nouvelle version du thème est disponible, celui-ci passe en version 0.3 et ajoute notamment les tags en bas de page.Les liens affichés dans le corps du billet sont également mise en évidence. Ciao !

Silvyn! Silvyn! ·  16 octobre 2009, 08:45

Mais c'est que c'est presque parfait tout ça :)
Bravo !

eric eric ·  26 octobre 2009, 23:39

salut à tous, je galere un peu concernant la consultation d'une page ajouté au blog.
contact s'affiche correct mais des que je clique sur une page : monsite.com/index.php?pages/A-propos et bien tout est décalé.
Si vous avez un tuyau, je suis preneur

eric eric ·  26 octobre 2009, 23:41

J'ai oublié, comment affichez vous le menu qui se trouve sous le bandeau?

Azork Azork ·  27 octobre 2009, 09:47

@Eric > Salut Eric, en ce qui concerne la page "A propos", je pense qu'il s'agit d'un plugin que tu as installé.Pourrais-tu me dire de quel plugin il s'agit et j'essaierais de mettre le thème à jour en conséquent.

Azork Azork ·  27 octobre 2009, 13:43

@Eric > Pour info, je viens de mettre à jour le thème qui passe en version 0.4 et qui est compatible avec le plugin Subscribe to comments.

Ciao !

eric eric ·  27 octobre 2009, 14:30

merci Azork, je vais tester mais j'ai quand même un problème de mise en page lorsque je créé des pages statiques. De plus, je ne sais pas comment avoir les menus qui se trouve juste en dessous du bandeau. Enfin, je n'ai pas l'impression que tous mes widgets se mettent en place dans la 2 et 3 colonne de droite.
Merci de m'indiquer la marche à suivre car je ne souhaite pas changer de themes, celui ci me correspond tout à fait, je n'ai pas trouvé une telle sobriété ailleurs. Merci pour ton aide Azork.

eric eric ·  27 octobre 2009, 15:02

pour voir le resultat merci de taper :
http://www.movingtimesmusic;com/ind...

en bas j'ai placé 2 liens "a propos" et "agenda". et voici le malheureux résultat.
je te confirme bien que les widgets placés dans le "bandeau de navigation " partie admin, ne s'affiche pas.
Les widgets placés dans la partie "bandeau d'extra" eux s'affichent correctement en pied de page.
j'ai tout regardé (chmod777) etc..

Azork Azork ·  27 octobre 2009, 15:22

@eric > Salut, je suis en train de regarder pour les pages statiques... en attendant tu pourrais mettre à jour le thème qui est passé en version 0.4. Récupère le thème sur mon site car la version sur dotaddict n'a pas été mise à jour.

eric eric ·  27 octobre 2009, 15:59

il y a du mieux dans la mesure où le bandeau à droite affiche désormais mes widgets.
Par contre toujours pas de menu en dessous du bandeau et toujours mon probleme de mise en page dans mes pages statiques
Merci pour ton travail.

Azork Azork ·  27 octobre 2009, 16:38

@eric > ok pour les pages statiques, tu utilises un plugin et donc j'ai créé un fichier template qui normalement va s'occuper de la mise en page (c'est le fichier external.html).Et pour ton deuxième problème de menu horizontal qui ne s'affiche pas, c'est tout simplement parce que tu n'as pas encore créé de catégories.Il te suffit juste d'aller dans la zone d'administration et de choisir Catégories ;-) tu verras que par la suite les catégories s'afficheront (à condition bien sur quelle contienne au minimum un billet).Pour te faciliter la tache j'ai de nouveau mise à jour le thème avec le fichier template et une modification au niveau de la feuille CSS. Donc pour résumer, télécharges de nouveau le thème qui se trouve sur mon site et tu verras qu'après les pages statiques de ton site fonctionneront sans problème ;-)

eric eric ·  27 octobre 2009, 22:08

Merci Azork pour ton travail, je n'ai pas encore testé mais tu as l'air sûr de toi, je te fais confiance ;-).
Je vais de ce pas faire les modifs.
Merci pour tout, je viendrais te confirmer le bon fonctionnement.

eric eric ·  27 octobre 2009, 22:35

Je te confirme, tout marche nickel. J'ai modifié le css pour les mettre aux couleurs de mon bandeau et j'ai vu que tu avais changé pas mal de choses.
Beau travail :20/20.
Merci beaucoup

xasalja xasalja ·  17 novembre 2009, 20:58

Salut Azork, merci pour ton thème, il est excellent !

J'aurais une question sans doute idiote mais bon...
Comment fais-tu pour que les posts et comments apparaissent effectivement dans la deuxième colonne ?? Je n'arrive pas à les y mettre...

Merci pour ton aide !

Azork Azork ·  18 novembre 2009, 18:36

@xasalja > Salut, quelle la version du thème que tu possèdes ?

Je te conseille te récupérer la version présente sur mon site et ensuite, tu pourras gérer les widgets sur la dernière colonnes.La deuxième colonne sert a afficher les billets sélectionnés !

Ciao !

xasalja xasalja ·  20 novembre 2009, 07:47

Ah ok, ça sert à afficher les billets sélectionnés, j'croyais que c'était les derniers billets !
Et les commentaire s'affichent bien sans rien ajouter dans les widgets de présentation, cool !
Et je viens de màj, j'étais en version 0.2 et là j'suis bien en 0.4. Le fichier sur dotaddict semble pas à jour du coup.

Merci pour ton aide !

Ignatius Ignatius ·  21 novembre 2009, 19:25

Bonjour Azork
Merci tout d'abord pour l'élégance de ce thème : je l'adopte.
J'ai téléchargé la version 0.4 qui améliore nettement les pages statiques.
Mais il y a encore des surprises : quand il s'agit d'une page connexe (mise à jour de fiches dans mon cas - onglet "producteurs"), sous le "à retenir", le résultat du fichier local s'affiche (inclus dans ton bloc #last-post-selected).

Bref, à toi de voir. Mais, d'abord, merci.

Azork Azork ·  21 novembre 2009, 20:15

@Ignatus > Salut et bienvenue. Pour ce qui est des pages connexes, ce n'est pas très compliqué à modifier.Pour effectuer une modification tu dois éditer le fichier "external.html" qui se trouve dans le répertoire tpl du thème hybrid. Ensuite tu trouveras dans la page le code suivant:

<div id="sidenav">
  <div id="c3">
    <div id="related-infos">
      <h2>{{tpl:lang Related information}}</h2>
      <ul>
        <li><strong>{{tpl:lang Published on}}:&nbsp;</strong>{{tpl:EntryDate format="%d %B %Y"}} &middot; {{tpl:EntryTime}} &middot; {{tpl:lang by}} {{tpl:EntryAuthorLink}}</li>
      </ul>
    </div>
    <div id="last-post-selected">
      <tpl:Entries no_context="1" selected="1" lastn="3" ignore_pagination="1">
        <tpl:EntriesHeader><h2>{{tpl:lang Best of me}}</h2></tpl:EntriesHeader>
        <h3><a href="{{tpl:EntryURL}}">{{tpl:EntryTitle encode_html="1"}}</a></h3>
        <p>{{tpl:EntryContent full="1" encode_html="1" remove_html="1" cut_string="120"}}...</p>
      </tpl:Entries>
    </div>
  </div>
  <!-- end #c3 -->
</div>
<!-- end #sidenav -->

C'est ici que tu peux éditer la sidenav. Si tu veux retirer la rubrique "À retenir", tu dois supprimer le bout de code suivant:

<div id="last-post-selected">
  <tpl:Entries no_context="1" selected="1" lastn="3" ignore_pagination="1">
    <tpl:EntriesHeader><h2>{{tpl:lang Best of me}}</h2></tpl:EntriesHeader>
      <h3><a href="{{tpl:EntryURL}}">{{tpl:EntryTitle encode_html="1"}}</a></h3>
      <p>{{tpl:EntryContent full="1" encode_html="1" remove_html="1" cut_string="120"}}...</p>
  </tpl:Entries>
</div>

ou tu peux le remplacer par un widget par exemple:

<tpl:Widget id="lastposts">
  <setting name="title"></setting>
  <setting name="homeonly">0</setting>
</tpl:Widget>

Pour être honnête, je ne vois pas d'où provient cette erreur...

Ignatius Ignatius ·  21 novembre 2009, 20:54

C'est fait et c'est beau et propre.
Alors je me permets une suggestion : les pages connexes, je trouve pratique de les appeler par un onglet dans le bandeau supérieur de navigation (à côté de Accueil, Archives...) : mais là j'ai dû intervenir directement sur home.html.
Dans le thème "Crazy Times", on peut "configurer le thème" : et c'est rudement pratique.
Merci aussi d'avoir répondu si rapidement.

Azork Azork ·  21 novembre 2009, 21:59

@ Ignatius > ok merci de l'info, j'essaierais de voir si je peux ajouter cette fonction... (c'est vrai que c'est plutôt pratique)

xasalja xasalja ·  29 novembre 2009, 14:33

J'aurais une dernière question : c'est normal que les bouts de texte qui devraient être soulignés ne le soient pas quand on regarde un billet ??

Je suis toujours autant fan du thème sinon. :p

Azork Azork ·  29 novembre 2009, 19:10

@xasalja > Salut, tu pourrais me donner une url où je puisse visualiser ton problème ? ... normalement les liens sont bien soulignés avec la dernière version du thème...

xasalja xasalja ·  29 novembre 2009, 22:42

Yo !
J'me suis mal exprimé, je parle pas des liens (qui sont bien soulignés, no soucis) mais juste des mots qu'on veut souligner (titres de livres par exemple).

Azork Azork ·  30 novembre 2009, 10:15

@xasalja > ok, tu dois éditer le fichier "reset.css" qui se trouve dans le répertoire du thème et ensuite changer la règle css ligne 48:

ins { text-decoration: none; }

par

ins { text-decoration: underline; }

Ciao !

xasalja xasalja ·  30 novembre 2009, 17:30

Aaah ok, j'croyais que c'était un bug mais c'est le thème qui est fait comme ça. Oui, va falloir que je m'attelle à quelques modifications.

Merci de ton aide, encore une fois !

Tu penses qu'il y aura de nouvelles versions du thème ??

Azork Azork ·  01 décembre 2009, 10:06

@xasalja > pas pour le moment, mais je travaille sur un prochain thème actuellement, so wait and see !

david-a david-a ·  02 décembre 2009, 19:31

Salut,
Je dis bravo, je dis merci, je dis merci et encore bravo :)

J'ai des petits soucis de "mise en forme" du texte des billets (en wiki), tu peux voir ça ici :
un billet avec hybrid
http://www.bloguspocus.fr/post/2009...
le même avec le thème par default de dotclear
http://www.bloguspocus.fr/blog1/

david-a david-a ·  03 décembre 2009, 07:58

Salut, j'ai pu corriger ces quelques PETITS problèmes (pour moi) en modifiant un peu les fichiers style.css et reset.css
:-)

Azork Azork ·  03 décembre 2009, 11:28

@david-a > Ok pas de soucis alors ;-)

david-a david-a ·  03 décembre 2009, 19:05

En revanche, surement une question idiote mais sur la page d'accueil à quoi servent Articles / Commentaires ? :-s

Azork Azork ·  03 décembre 2009, 19:59

@david-a > l'un pour afficher les articles sélectionnés, l'autre pour afficher les derniers commentaires des billets...

Elodie Elodie ·  05 janvier 2010, 19:30

Bonjour,
je rencontre un bug à l'usage :
dans le bandeau de navigation - si dans un widget texte, j'enfile une image et un lien sur cette image et qu'à la suite je colle un widget "fil de nouvelles" avec un TITRE , alors le TITRE de ce dernier hérite du lien établi dans mon premier widget...
Je ne comprends pas pourquoi :-(

Elodie Elodie ·  05 janvier 2010, 19:37

Et un deuxième que je n'arrive pas à résoudre : impossible de modifier le nombre de billets affichés sur la page d'accueil => j'ai beau lui dire d'en afficher 8, il reste bloqué à 5... ? ?

Azork Azork ·  07 janvier 2010, 16:36

@Elodie > Salut, concernant ta première question, est-ce tu pourrais me donner un lien vers ton site ou je puisse visualiser ton problème stp ? Pour répondre à ta deuxieme question, il faut modifier le code suivant <tpl:Entries lastn="5"> par la valeur que tu souhaites !

Ciao

Calamo Calamo ·  21 février 2010, 23:44

Bonjour Azork,

Je rencontre un petit problème avec la home du thème (aussi bien en v2 qu'en v5).

J'ai fusionné c1 et c2 afin de publier en sidebar les billets d'une catégorie en particulier, sous forme de liste, avec titre/infos/chapeau ou contenu entier.

Les chapeaux, par exemple, sont appelés par :
{{tpl:EntryExcerpt remove_html="1" encode_html="1" }}

Pour la mise en forme des chapeaux, j'ai repris la p class "preview comment", en suivant les conseils que tu m'avais donnés sur un autre site de support, ce qui donne :
<p class="preview-comment">{{tpl:EntryExcerpt remove_html="1" encode_html="1" }}</p>

Dans le fichier style.css, j'ai précisé la mise en forme que je souhaite en précisant .dc-home #sidenav p.preview-comment, et ça marche.

Sauf que... si je supprime remove_html="1" encode_html="1", la mise en forme devient celle des "default tags" qui figurent en tête du fichier style.css, sous l'entrée p {

J'ai essayé différentes "façons" de faire appliquer le style prévu par #sidenav p.preview-comment dans le fichier style.css, notamment en modifiant le fichier home.html, le nom de la classe, etc., mais rien n'y fait, et je n'ai pas trouvé d'infos sur ce point dans la doc DC2, à propos des filtres.

Si tu as une suggestion...

Merci d'avance de ta réponse, quoi qu'il en soit.

Azork Azork ·  22 février 2010, 18:56

@Calamo > Salut, si tu veux donner plus d'importance à une classe présente dans le fichier de styles, alors tu dois rajouter ceci !important

Par exemple:

p.preview-comment { margin-bottom: 0 !important; }

Tu peux également indiquer que tous les éléments p descendants de la classe .preview-comment soient pris en compte:

p.preview-comment > p { margin-bottom: 0; }

Ça devrait fonctionner !

Zoomy Zoomy ·  25 juillet 2010, 17:33

Bonjour,

Je découvre ce theme que je trouve super, mon probleme est la fonction recherche qui fonctionne pas quand j'envoie la requetela page ne change pas et ca rajoute le "q=xxx au bout de l'url présente

Si qq1 à une idée ?

merci

Azork Azork ·  29 juillet 2010, 15:26
@Zoomy > Salut, la recherche fonctionne normalement très bien. As-tu essaye de réinstaller Dotclear et de télécharger la dernière version du thème ? (disponible sur ce site)
Cyberia Cyberia ·  09 mars 2011, 11:35

bonjour et merci pour ce thème,

j'ai différents petite question:

1- sur la page d'accueil il y a une colonne article à quoi sert-elle ?
2- quand on clique sur un billet,je voudrais que le bandeau de navigation s'affiche sur la droite, comment faire ?
3- dans le header j'aimerais mettre une image, quel fichier je dois modifier ?

Merci encore de votre aide et de votre travail.

Cordialement.

Cyberia Cyberia ·  09 mars 2011, 18:23

Re,

bon pour le header j'ai trouver..

Cyberia Cyberia ·  09 mars 2011, 20:59

Encore moi, bon plus besoin de vos services, j'ai trouver comment faire toutes mes modifications.
Merci pour le thème....

Azork Azork ·  09 mars 2011, 21:15

@ Cyberia > Pas de soucis !  N'hésites pas également à visiter forum dotclear si tu as d'autres problèmes...

pressecologie pressecologie ·  30 mars 2011, 11:53

Bonjour,

Suis en panique, je voulais installé le plgin agenda et il me semble que ça marche pas avec ton theme ...
As tu essayé ?

Cordialement.

pressecologie pressecologie ·  30 mars 2011, 13:40

Effectivement le plugin agenda est trop vieux. J'ai quand même quelque problème avec le plugin Event handler 1.0-RC1 pour la mise en page...
Cordialement.

Azork Azork ·  31 mars 2011, 10:25

@pressecologie > Salut, pourrais-tu donner plus de détails concernant la nature du problème avec le plugin (non je n'ai pas essaye ce plugin). Il est probable que le thème ne fonctionne pas avec certains plugins car celui-ci utilise une structure html différente de celle par défaut. Malheureusement, comprends bien que je ne peux pas tester et corriger tous les plugins existants pour les rendre compatible avec mon thème. Je pense que ton problème se trouve au niveau du template html utilise par le plugin. Il te faudra copier les fichiers html utilisés par le plugin, les collés dans le dossier TPL du thème hybrid et en changés la structure. Ensuite tu peux prendre exemple sur la méthodologie décrite ici http://forum.dotclear.net/viewtopic.php?pid=296214

J’espère que ça t'aidera à mieux comprendre. N’hésites pas si le problème persiste, et regarde également sur le forum dotclear si d'autres personnes peuvent te donner un coup de main.

Ciao

aucune annexe



À voir également

slideshow.jpg

Comment intégrer un slideshow avec Dotclear?

Découvrez dans cet article la mise en place d'un slideshow avec le CMS Dotclear.

Lire la suite

chestnut.jpg

Thème Dotclear - Chestnut

Chestnut est un thème gratuit pour Dotclear 2. C'est un thème conçu sur une structure en 2 colonnes. Le thème est compatible avec les différents widgets.

Lire la suite