Le blog d'Azork

Design, techniques et ressources gratuites pour votre site web.

Aller au contenu | Aller au menu | Aller à la recherche

Thème Dotclear - Chestnut

Theme Chestnut

Détails

  • Version du thème : 1.0
  • Licence : domaine public
  • Support : Forum Dotclear

Informations complémentaires

version 1.0

  • Suppression de la marge qui apparaissait si un billet ne comportait aucune image
  • Changement de la taille de la police pour la classe .post-content à 12pixels

version 0.9

  • Corrections HTML (le thème est valide XHTML 1.0 Strict)
  • La page d’accueil affiche dorénavant les billets par ordre de publication (j'ai laissé également dans le thème le fichier tpl pour afficher les billets par catégorie si besoin)
  • Ajout d'un lien vers les commentaires en bas de chaque billets
  • Optimisation du code pour certains fichiers TPL du thème
  • Quelques corrections CSS

version 0.8

  • Compression de la feuille de styles (une version non-compressé est également incluse)
  • Optimisation des images
  • Optimisation du code pour certains fichiers TPL du thème
  • Quelques corrections CSS

version 0.7

  • Modification de la source du fichier Jquery (l'appel du script utilise le fichier Jquery du thème par défaut)
  • Si l'extrait d'un billet n'existe pas alors le contenu principal du billet sera affiché
  • Correction CSS pour l'affichage des smileys

version 0.6

  • Corrige un problème de validation avec l'outil de recherche
  • Modification du comportement des billets en page d’accueil. Seul l'extrait du billet est dorénavant affiché.
  • Diverses corrections CSS
version 0.5
  • Correction du code pour l'affichage du sous-menu (le code est dorénavant valide XHTML strict)

version 0.4

  • Corrige un problème d'affichage des archives avec Google Chrome
  • Corrige un problème d'affichage en page d’accueil
Azork

Auteur: Azork

Restez au courant de l'actualité et abonnez-vous au Flux RSS de cette catégorie

Commentaires (42)

Hiko Seijûrô Hiko Seijûrô ·  15 juin 2011, 01:19

J'ai bien ce thème et j'ai deux questions à te poser.
Première question : sur la page home il y a une div slider qui affiche trois articles en boucle. Comment fonctionne le système d'arrière plan ? Sur ton blog il y a une image en arrière plan, comment je peux faire de même ? Sans ces images il y a un vide sur la page qui me gène assez.
Deuxième question : il semble que se soit les articles sélectionnés qui s'affichent dans cette div. Peut-on changer ce comportement ? (Par exemple afficher les trois dernières publications)

Azork Azork ·  15 juin 2011, 21:38

@Hiko> Salut, tu trouveras des informations sur un des mes posts que j'ai laissé sur le forum dotclear (post numéro #37).
Pour changer la structure du slider, tu peux éditer le fichier featured-home.html. Il suffit de chnager le code suivant

<tpl:Entries lastn="3" selected="1">

par celui-ci

<tpl:Entries lastn="3">
bricedeparis bricedeparis ·  05 juillet 2011, 17:25

Bonjour,

Je voulais adopter ton thème que je trouve très réussi...
Je suis assez novice dans ce domaine.
Ma question va être un peu plus large que ce qui constitue ton travail, mais quel que soit le thème, le tien ou un autre du même type, il ne m'est plus possible depuis mon passage à Dotclear 2.3 d'avoir des images de une (comme celle de ta home associée à chaque article mis en avant, le slider); Quoi que je fasse, quel que soit le format que j'utilise et où que je place cette image, la référence ne se fait plus, et je n'arrive pas à trouver de solution.
Si, au passage, tu avais une idée ! Merci par avance.
J'aimerais beaucoup adopter ton thème, mais avec un vide d'image en home, c'est vraiment très frustrant ! :(

Brice

Azork Azork ·  05 juillet 2011, 18:24

@bricedeparis > Salut, lorsque tu édites/ajoutes un nouveau billet, il suffit juste d'ajouter une image au tout début (onglet visuel pour être sur que ton image s'affiche correctement). Ensuite, sélectionnes l'onglet source (de ton billet) et ajoutes les balises suivantes <!-- --> entre la balise de ton image, ce qui donnera quelque chose comme ça <!-- <img src=... > -->

Par exemple, le début de ce billet commence comme ça

<!--<img src="/public/themes/chestnut/chestnut.jpg" alt="chestnut.jpg" />-->
<p><a href="/public/themes/chestnut/theme-chestnut.jpg" title="Theme Chestnut">
<img src="/public/themes/chestnut/theme-chestnut.jpg" alt="Theme Chestnut" title="Theme Chestnut" />
</a>
</p>
<div class="action">
<a href="http://xtradotfreedotfr.free.fr/public/themes/chestnut/theme-chestnut.zip" class="download">Télécharger</a>
<a href="http://themes.dotaddict.org/demo-dc2?theme=chestnut" class="view">Aperçu</a>
</div>
<h3>Détails</h3>
patrick patrick ·  22 juillet 2011, 15:44

Bonjour
Je suis pas très douer avec les codes ,alors juste une petite question ,comment peut on faire pour avoir toutes les catégories afficher comme les six premiers sur la pages d'accueil merci d'avance et bravo pour ce thème il est super.
Amicalement patrick

Azork Azork ·  24 juillet 2011, 11:19

@patrick > il faut que tu édites le fichier categories-home.html.
La première boucle commence à la ligne 2:

 <tpl:LoopPosition start="1" length="6">

La deuxième boucle commence à la ligne 49:

 <tpl:LoopPosition start="7" length="2">

patrick patrick ·  27 juillet 2011, 07:12

Bonjour
Merci pour ta réponse, super thème bravo
Amicalement patrick

Bob Bob ·  02 août 2011, 08:20

Oh qu'il est beau ce thème. Pratique, sobre, techniquement bien roulé. Et en plus récent et compatible avec plein de widgets.
On a envie de s'en servir. Bravo!

Je vais tenter l'install sur un prochain site :)
olymp_us642 olymp_us642 ·  02 août 2011, 18:59

Bonjour
En fait j'ai 3 questions à poser : je suis en train de tester différents thèmes dont Chestnut et ... Demo#1. Pour ce dernier, j'ai le problème suivant : les listes numérotées s'affichent avec des petits cercles avant chaque item et non avec des chiffres.
Pour Chestnut pas moyen d'avoir les images qui s'affichent dans le slider, pourtant images intégrées dans le billet, commentées ou non au début du code html, billets sélectionnés... je ne comprends pas, j'ai dû oublier quelque chose ?
Enfin, dernière question : dans ton tuto sur l'intégration d'un slide, tu utilises le plugin SyntaxHighlighter que je connais pour l'avoir testé dans Dokuwiki, mais je voudrais savoir comment l'intégrer à Dotclear ; il ne fait pas partie des plugins officiels, j'ai essayé en utilisant le code html généré sur le site syntaxhighlighter.relic19.net mais ça n'a pas marché en intégrant ce code tel que dans un billet.
Merci d'avance pour tes réponses !

Azork Azork ·  04 août 2011, 08:39

@Bob > Merci et bon courage pour ton install ;-)

@Olymp_us642 > As-tu une adresse ou je puisse voir ton site en action ?
Je te conseille de regarder avec Firebug si tes images se chargent correctement (c'est possible que le chemin vers l'image ne soit pas correct).
En ce qui concerne SyntaxHighlighter, j'ai rajouter le script dans mon fichier _head.html, puis effectivement je génère le code via le site syntaxhighlighter.relic19.net.
Si tu une url ça serait plus simple pour voir d’où vient ton problème. Sinon je te conseille d'utiliser Firebug.

olymp_us642 olymp_us642 ·  04 août 2011, 10:21

Merci pour tes réponses. Comme je ne maîtrise pas vraiment firebug, je te mets mon URL.
Pour continuer à décrire mon problème, je précise que j'ai désinstallé/réinstallé le thème, j'ai enlevé toutes les extensions perso, fait du ménage avec clean:config, j'ai mis aussi le chemin vers l'image en lien absolu (ayant un multi-blogs)... et ça ne fonctionne toujours pas.

Azork Azork ·  04 août 2011, 20:45

@olymp_us642 > si tu regarde le code source de page, tu verras qu'il n'y a pas d'image insérée, et donc normal que le slideshow n'affiche rien...Va voir du coté du forum dotclear, c'est peut-être un problème avec ton hébergeur ou peut-être le fait que tu sois en multiblog... Sinon essaies également de recréer un billet avec une image insérée.

Malko Malko ·  08 août 2011, 15:04

Très beau thème, je vais l'adopter, l'adapter à mon blog!

olymp_us642 olymp_us642 ·  12 août 2011, 16:51

Bonjour
J'ai enfin résolu mon problème d'affichage des images dans le slider... il y avait juste le "petit détail qui tue" : l'url de mon dossier public n'était pas bien configurée dans about:config.
J'ai également posté dans le forum dotclear pour "avouer" mon erreur.
En tous cas, bravo pour ce thème très bien conçu !
P.S. une petite idée pour mon problème avec Demo#1 ?... mais je vais poster là où il faut

Djouls Djouls ·  16 août 2011, 01:12

Hello. Tres bien ce thème, je l'ai installé pour Paris DJs et j'ai à peine commencé à le tritouillé. Le code est bien propre, c'est bien pensé, bravo (et merci) !!

Azork Azork ·  16 août 2011, 08:43

@Djouls > Si tu es un peu patient, une mise à jour du thème sera bientôt disponible. Pas de grands changements, juste quelques corrections de code (CSS et HTML) et quelques réglages. Tu peux voir certains changements sur mon blog, comme par exemple la taille des vignettes sur la page des catégories (j'ai agrandi un peu la taille), la suppression du champ annexe dans la page des archives...

Bart Bart ·  17 août 2011, 15:42

Salut,

Bravo pour ce thème... Il est top !
J'ai juste un petite question : Est-ce qu'il y a un moyen pour que la catégorie sur la home qui apparaisse en premier soit celle du dernier article publier ?

Azork Azork ·  17 août 2011, 20:47

@Bart > Je crois que tu peux modifier l'ordre des catégories via la zone d'administration de dotclear (suis pas sur)... tu devrais poser ta question sur le forum

Bart Bart ·  18 août 2011, 09:46

Merci pour ta réponse.
J'ai une autre question... Au lien d'avoir 2 colonne par ligne (avec à 1 catégorie à chaque fois), j'aimerai avoir 1 seule colonne (donc, 1 catégorie par ligne)... où est ce que je pourrais mettre la main sur le bout de code ?

Bart Bart ·  19 août 2011, 11:32

Une autre petite question : Comment fait on pour afficher plus de 3 articles dans chaque catégorie sur la home ?
Impossible de mettre la main dessus !

CDM FIFA CDM FIFA ·  27 août 2011, 09:57

Félicitations pour ce bô travail !

Moi aussi, je viens de l'adopter.

pressecologie pressecologie ·  29 août 2011, 12:47

Bonjour Azork,

J'ai un problème de texte qui s'affiche en même temps (titre h2 du slider) au premier chargement du site. Je remarque que tu n'a pas ce problème sur ton slider.
J'ai cherché une solution, sans succès pour le moment.
Je voulais savoir si tu avais une idée pour corriger ce problème.

Cordialement.

Azork Azork ·  31 août 2011, 12:40

@Bart > Tu devras éditer le fichier categories-home.html qui se trouve dans le thème.
Pour les changements spécifiques à ton site, je te conseille plutôt de demander de l'aide sur le forum Dotclear.
Ciao

Azork Azork ·  31 août 2011, 21:22

@pressecologie > Salut, je ne voie pas de soucis particuliers sur ton site, as-tu toujours le même problème ?

CDM FIFA CDM FIFA ·  01 septembre 2011, 09:11

Slt,
Comme toi je suis hébergé chez Free et je constate que lorsque tu es sur un billet, tu peux naviguer entre les liens articles- commentaires - annexes avec un joli effet de transition.
Sur mon site, ça ne fonctionne pas pourtant je n'ai touché à rien (excepté le fichier _top.html) que j'ai personnalisé avec une petite bannière et des images.
Aurais-tu une idée de la provenance de cette différence ?
Merci.
Voici l'URL : http://cdmfifa.free.fr/

CDM FIFA CDM FIFA ·  01 septembre 2011, 12:13

Cela fonctionne, j'ai trouvé en comparant ton code source au mien.

Ils manquaient deux balises </li> chez moi dans <div id="tabs">.

Désolé pour le dérangement mais je ne suis pas un expert en la matière.

Bonne journée.

Alain Dubois Alain Dubois ·  12 septembre 2011, 13:29

Bravo pour ce thème!

Dès les premières heures d'utilisation j'ai eu plusieurs félicitations pour ton thème.

Merçi!

Alain

CDM FIFA CDM FIFA ·  15 septembre 2011, 09:04

Trop fort ce Azork !

Azork Azork ·  15 septembre 2011, 18:45

@Alain Dubois & CDM FIFA > Merci à vous, ça fait plaisir !

sunnmagic sunnmagic ·  25 septembre 2011, 15:17

Bonjour à tous,

J'ai beau suivre tous les conseils pour le slide, il reste désespérément vide... Please help > http://blog.play3-live.com/p3l/ :)

CDM FIFA CDM FIFA ·  18 octobre 2011, 12:03

Salut,

As-tu bien déclaré tous les fichiers javascript dans user_head.html et _head.html (Fichiers template) comme le Patron le décrit dans son exposé ?

Revoie ça éventuellement, moi pour éviter tout problème, je les ai mis à la racine ce qui donne pour
_head.html :

<script type="text/javascript" src="jquery.js"></script>
<script type="text/javascript" src="jquery.cookie.js"></script>
<script type="text/javascript" src="jquery.cycle.min.js"></script>
<script type="text/javascript" src="jquery-ui-1.8.10.custom.min.js"></script>
<script type="text/javascript" src="main.js"></script>
<script type="text/javascript" src="post.js"></script>

Vérifie ce bloc mais n'efface pas les autres données !

ChuTn3Y ChuTn3Y ·  20 octobre 2011, 10:48

Bonjour,

j'ai migré un blog de test sur un autre hébergement (1&1) et depuis (du moins, je ne m en suis pas rendu compte avant!) j'ai un soucis sur mon theme chestnut, le slider sur la page d'accueil ne fonctionne plus. et je vois le 2ème article sous le 1er (en transparence)
j'ai essayé de recharger le css du theme original & pareil pour les fichiers html mais ça ne règle pas mon problème. j'ai même réuploadé les fichier .js originaux...

quelqu'un aurait il une idée car là je ne vois pas de quel coté je dois regarder....
merci pour votre aide.

pour avoir une idée du problème : http://s386812211.onlinehome.fr/ind...

merci pour votre aide.

Azork Azork ·  20 octobre 2011, 18:00

@ChuTn3Y > Salut, j'ai l'impression que tout fonctionne de nouveau sur ton site... en tout cas le slider fonctionne ;-)

Marco Marco ·  20 novembre 2011, 11:55

Bonjour,

Où dois-je intervenir pour augmenter le nombre de réactions affichées en page d'accueil?

Merci par avance et merci aussi pour ce thème très très très réussi

Marco

Azork Azork ·  24 novembre 2011, 09:25

@ Marco > Salut, tu dois éditer le ficheir sidebar.html du thème et modifier la ligne (lastn correspondant au nombre de reactions que tu veux afficher)

<tpl:Comments lastn="3" order="desc" with_pings="0">
stephane stephane ·  07 décembre 2011, 16:51

J'ai rien a demandé, rien a signalé !!!
Juste dire felicitations, c'est pour moi le meilleur theme existant sur d'autre dotclear ! J'administre 2 dotclear au boulot et 3 perso, et je suis deja au deuxieme blog en cours de conversion sur ton theme....

Felicitations pour ce boulot, et surtout merci !

Azork Azork ·  07 décembre 2011, 19:07

@ stephane > Merci

JiPeheL JiPeheL ·  13 décembre 2011, 20:58

Bonsoir Azork,
Je ne serai pas très original, merci pour ce beau thème qui fait avancer Dotclear !

J'ai trois questions sous le chapeau :

1- les liens ne se voient pas dans le châpo, est-ce à dire que cela n'est pas souhaité ?
2- est-il possible de visualiser la totalité du châpo dans le slider ?
3- ou alors, à la lecture de la suite, pourrait-on voir le châpo et le texte du billet comme cela se fait dans pas mal de thèmes.

Merci !

C'est ici http://photo-nature-passion.com

CDM FIFA CDM FIFA ·  19 décembre 2011, 17:01

Azork Président !

Azork Azork ·  19 décembre 2011, 21:27

@JiPeheL > Pour modifier le slideshow, il faut éditer le fichier featured-home.html du thème. Ensuite tu peux modifier le code pour afficher la totalité du texte ou autre...je te conseille de regarder la documentation officielle sur le site Dotclear.

@CDM FIFA > Merchi merchi :-)

JiPeheL JiPeheL ·  23 décembre 2011, 16:52

Merci Azork pour ton aide, je patine toujours pour avoir la totalité du châpo dans le slider (et pas plus).

Je ne désespère pas !

Bonnes fêtes !

CDM FIFA CDM FIFA ·  04 janvier 2012, 14:11

Bonne année Azork.

aucune annexe



À voir également

slideshow.jpg

Comment intégrer un slideshow avec Dotclear?

Découvrez dans cet article la mise en place d'un slideshow avec le CMS Dotclear.

Lire la suite

tabloid.jpg

Thème Dotclear - Tabloid

Tabloid est un thème gratuit pour Dotclear 2. C'est un thème conçu sur une structure en 2 colonnes. Le thème est compatible avec les différents widgets.

Lire la suite